using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?:ithelpdesk(?:|\d+)|deskserverithelp|itservicedeskhelp|ithelpservice(?:|\d+))@gmail.com)";
string substitution = @"";
string input = @"ithelpdesk458@gmail.com
ithelpdesk@gmail.com
deskserverithelp@gmail.com
itservicedeskhelp@gmail.com
";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}