#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?im)((?:ithelpdesk(?:|\d+)|deskserverithelp|itservicedeskhelp|ithelpservice(?:|\d+))@gmail.com)"
Local $sString = "ithelpdesk458@gmail.com" & @CRLF & _
"" & @CRLF & _
"ithelpdesk@gmail.com" & @CRLF & _
"" & @CRLF & _
"deskserverithelp@gmail.com" & @CRLF & _
"" & @CRLF & _
"itservicedeskhelp@gmail.com" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)