re = /My dog's name is (.*)\./m
str = '
Sally said, "My dog\'s name is Fido."
Billy replied, "I have a cat named Spot."'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end