$re = '/My dog\'s name is (.*)\./m';
$str = '
Sally said, "My dog\'s name is Fido."
Billy replied, "I have a cat named Spot."';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);