package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)My dog's name is (.*)\.`)
var str = `
Sally said, "My dog's name is Fido."
Billy replied, "I have a cat named Spot."`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}