using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"My dog's name is (.*)\.";
string input = @"
Sally said, ""My dog's name is Fido.""
Billy replied, ""I have a cat named Spot.""";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}