import Foundation
let pattern = #"node\.([[:alnum:]]*?)\."#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
// Print `Hello, world!` every one second.
if (Global.currentFrame % Global.targetFPS == 0) {
print(node.sensorlink.encoder1Position) //.encoder1Position);
// print(node.sensorlink.encoder1Position) //.encoder1Position);
"print(node.sensorlink.encoder1Position) //.encoder1Position);"
'print(node.sensorlink.encoder1Position) //.encoder1Position);'
}
// Node("sensorlink").encoder2PositionRelative
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)