$re = '/node\.([[:alnum:]]*?)\./m';
$str = '// Print `Hello, world!` every one second.
if (Global.currentFrame % Global.targetFPS == 0) {
print(node.sensorlink.encoder1Position) //.encoder1Position);
// print(node.sensorlink.encoder1Position) //.encoder1Position);
"print(node.sensorlink.encoder1Position) //.encoder1Position);"
\'print(node.sensorlink.encoder1Position) //.encoder1Position);\'
}
// Node("sensorlink").encoder2PositionRelative
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);