package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)node\.([[:alnum:]]*?)\.`)
var str = `// Print \`Hello, world!\` every one second.
if (Global.currentFrame % Global.targetFPS == 0) {
print(node.sensorlink.encoder1Position) //.encoder1Position);
// print(node.sensorlink.encoder1Position) //.encoder1Position);
"print(node.sensorlink.encoder1Position) //.encoder1Position);"
'print(node.sensorlink.encoder1Position) //.encoder1Position);'
}
// Node("sensorlink").encoder2PositionRelative
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}