// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)node\.([[:alnum:]]*?)\.").unwrap();
let string = "// Print `Hello, world!` every one second.
if (Global.currentFrame % Global.targetFPS == 0) {
print(node.sensorlink.encoder1Position) //.encoder1Position);
// print(node.sensorlink.encoder1Position) //.encoder1Position);
\"print(node.sensorlink.encoder1Position) //.encoder1Position);\"
'print(node.sensorlink.encoder1Position) //.encoder1Position);'
}
// Node(\"sensorlink\").encoder2PositionRelative
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}