re = /([a-zA-Z0-9]*?)[_.-]*([a-zA-Z0-9]*?)\.(com|co\.uk|org|net)\b/m
str = 'email.apple.com
hsn.com
alerts.comcast.net'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end