$re = '/([a-zA-Z0-9]*?)[_.-]*([a-zA-Z0-9]*?)\.(com|co\.uk|org|net)\b/m';
$str = 'email.apple.com
hsn.com
alerts.comcast.net';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);