#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)([a-zA-Z0-9]*?)[_.-]*([a-zA-Z0-9]*?)\.(com|co\.uk|org|net)\b"
Local $sString = "email.apple.com" & @CRLF & _
"hsn.com" & @CRLF & _
"alerts.comcast.net"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")