package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([a-zA-Z0-9]*?)[_.-]*([a-zA-Z0-9]*?)\.(com|co\.uk|org|net)\b`)
var str = `email.apple.com
hsn.com
alerts.comcast.net`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}