re = /(([\|&]|return|[^=<>|\*]=|\(|\[)\s*)([a-zA-Z\._]+)\s*\?\s*\3\s*:\s*/m
str = 'SHOULD NOT MATCH
(value <= low ? low : (value >= high ? high : value))
SHOULD MATCH
res = a || b?b:c
res = a || b?b:c?c:d
res = a?a:b?b:c?c:d?d:e?e:"f"
res = a?a:b?b: c?c: d?d : e ?e : "f"
return GLOB.using_map.system_name ? GLOB.using_map.system_name : generate_system_name()
foo = bar ? bar : "john"
var=joo?joo:juu
proc(foo? foo : bar)
if(baz?baz:car)'
subst = '\\1\\3 || '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result