# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(([\|&]|return|[^=<>|\*]=|\(|\[)\s*)([a-zA-Z\._]+)\s*\?\s*\3\s*:\s*"
test_str = ("SHOULD NOT MATCH\n"
"(value <= low ? low : (value >= high ? high : value))\n\n"
"SHOULD MATCH\n"
"res = a || b?b:c\n"
"res = a || b?b:c?c:d\n"
"res = a?a:b?b:c?c:d?d:e?e:\"f\"\n"
"res = a?a:b?b: c?c: d?d : e ?e : \"f\"\n"
"return GLOB.using_map.system_name ? GLOB.using_map.system_name : generate_system_name()\n"
"foo = bar ? bar : \"john\"\n"
"var=joo?joo:juu\n"
"proc(foo? foo : bar)\n"
"if(baz?baz:car)")
subst = "\\1\\3 || "
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.