// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\/car-finance\/home\/(.*)\?t=(.*)&w=1").unwrap();
let string = "/car-finance/home/3f737e9c-dd36-4995-998e-eb33cdfec70f?t=SE[…]Hc+wXfuf7ZyyszX2p/i4OpnuU3buTHAu3DYDpbr53h8s2gC+IgDxvVsijVs&w=1";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}