const regex = /\/car-finance\/home\/(.*)\?t=(.*)&w=1/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\\/car-finance\\\/home\\\/(.*)\\?t=(.*)&w=1', 'gm')
const str = `/car-finance/home/3f737e9c-dd36-4995-998e-eb33cdfec70f?t=SE[…]Hc+wXfuf7ZyyszX2p/i4OpnuU3buTHAu3DYDpbr53h8s2gC+IgDxvVsijVs&w=1`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}