re = /\/car-finance\/home\/(.*)\?t=(.*)&w=1/m
str = '/car-finance/home/3f737e9c-dd36-4995-998e-eb33cdfec70f?t=SE[…]Hc+wXfuf7ZyyszX2p/i4OpnuU3buTHAu3DYDpbr53h8s2gC+IgDxvVsijVs&w=1'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end