#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\/car-finance\/home\/(.*)\?t=(.*)&w=1"
Local $sString = "/car-finance/home/3f737e9c-dd36-4995-998e-eb33cdfec70f?t=SE[…]Hc+wXfuf7ZyyszX2p/i4OpnuU3buTHAu3DYDpbr53h8s2gC+IgDxvVsijVs&w=1"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")