import Foundation
let pattern = #"\/([a-zA-Z0-9-]+)(?=[^\/]*$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
[
{
"id": "https://asdf.com/lti/api/132456/lineitems/5c3f2665-198c-4895-bd52-8c766f528839",
"startDateTime": "2020-10-28 15:26:53.731",
"endDateTime": "2020-10-29 15:26:53.731",
"label": "Performance Test",
"resourceId": "This is resource",
"resourceLinkId": "This is resource link id",
"scoreMaximum": 1,
"tag": "This is tag"
},
{
"id": "https://asdf.com/lti/544ddaf1-f248-4fa3-983b-938f531fd78f",
"startDateTime": "2920-10-28 15:26:53.731",
"endDateTime": "2920-10-29 15:26:53.731",
"label": "Performance Testing 2",
"resourceId": "This is resource",
"resourceLinkId": "This is resource link id",
"scoreMaximum": 1,
"tag": "This is tag"
}
]
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)