use strict;
my $str = '[
{
"id": "https://asdf.com/lti/api/132456/lineitems/5c3f2665-198c-4895-bd52-8c766f528839",
"startDateTime": "2020-10-28 15:26:53.731",
"endDateTime": "2020-10-29 15:26:53.731",
"label": "Performance Test",
"resourceId": "This is resource",
"resourceLinkId": "This is resource link id",
"scoreMaximum": 1,
"tag": "This is tag"
},
{
"id": "https://asdf.com/lti/544ddaf1-f248-4fa3-983b-938f531fd78f",
"startDateTime": "2920-10-28 15:26:53.731",
"endDateTime": "2920-10-29 15:26:53.731",
"label": "Performance Testing 2",
"resourceId": "This is resource",
"resourceLinkId": "This is resource link id",
"scoreMaximum": 1,
"tag": "This is tag"
}
]';
my $regex = qr/\/([a-zA-Z0-9-]+)(?=[^\/]*$)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}