import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\/([a-zA-Z0-9-]+)(?=[^\\/]*$)";
final String string = "[\n"
+ " {\n"
+ " \"id\": \"https://asdf.com/lti/api/132456/lineitems/5c3f2665-198c-4895-bd52-8c766f528839\",\n"
+ " \"startDateTime\": \"2020-10-28 15:26:53.731\",\n"
+ " \"endDateTime\": \"2020-10-29 15:26:53.731\",\n"
+ " \"label\": \"Performance Test\",\n"
+ " \"resourceId\": \"This is resource\",\n"
+ " \"resourceLinkId\": \"This is resource link id\",\n"
+ " \"scoreMaximum\": 1,\n"
+ " \"tag\": \"This is tag\"\n"
+ " },\n"
+ " {\n"
+ " \"id\": \"https://asdf.com/lti/544ddaf1-f248-4fa3-983b-938f531fd78f\",\n"
+ " \"startDateTime\": \"2920-10-28 15:26:53.731\",\n"
+ " \"endDateTime\": \"2920-10-29 15:26:53.731\",\n"
+ " \"label\": \"Performance Testing 2\",\n"
+ " \"resourceId\": \"This is resource\",\n"
+ " \"resourceLinkId\": \"This is resource link id\",\n"
+ " \"scoreMaximum\": 1,\n"
+ " \"tag\": \"This is tag\"\n"
+ " }\n"
+ "]";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}