using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\/([a-zA-Z0-9-]+)(?=[^\/]*$)";
string input = @"[
{
""id"": ""https://asdf.com/lti/api/132456/lineitems/5c3f2665-198c-4895-bd52-8c766f528839"",
""startDateTime"": ""2020-10-28 15:26:53.731"",
""endDateTime"": ""2020-10-29 15:26:53.731"",
""label"": ""Performance Test"",
""resourceId"": ""This is resource"",
""resourceLinkId"": ""This is resource link id"",
""scoreMaximum"": 1,
""tag"": ""This is tag""
},
{
""id"": ""https://asdf.com/lti/544ddaf1-f248-4fa3-983b-938f531fd78f"",
""startDateTime"": ""2920-10-28 15:26:53.731"",
""endDateTime"": ""2920-10-29 15:26:53.731"",
""label"": ""Performance Testing 2"",
""resourceId"": ""This is resource"",
""resourceLinkId"": ""This is resource link id"",
""scoreMaximum"": 1,
""tag"": ""This is tag""
}
]";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}