re = /^([A-Za-z0-9._]*)@([A-Za-z0-9_.]*)/m
str = 'lubo_mir.ni_kl@gma.il.com
frANta@krbec.cz
_info_@_domain_.co.uk'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end