package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([A-Za-z0-9._]*)@([A-Za-z0-9_.]*)`)
var str = `lubo_mir.ni_kl@gma.il.com
frANta@krbec.cz
_info_@_domain_.co.uk`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}