use strict;
my $str = 'lubo_mir.ni_kl@gma.il.com
frANta@krbec.cz
_info_@_domain_.co.uk';
my $regex = qr/^([A-Za-z0-9._]*)@([A-Za-z0-9_.]*)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}