$re = '/^([A-Za-z0-9._]*)@([A-Za-z0-9_.]*)/m';
$str = 'lubo_mir.ni_kl@gma.il.com
frANta@krbec.cz
_info_@_domain_.co.uk';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);