re = /\A(?:(?=[a-zA-Z0-9])(?=[\w@\-.]{1,128}\z)(?=[\w.-]+[a-zA-Z0-9]@)[\w-]+(?:\.[\w-]+)*@(?:[0-9a-zA-Z][-\w]*[0-9a-zA-Z\.]){1,2}[a-zA-Z]{2,9})\z/m
str = 'aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa@test.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end