import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\A(?:(?=[a-zA-Z0-9])(?=[\\w@\\-.]{1,128}\\z)(?=[\\w.-]+[a-zA-Z0-9]@)[\\w-]+(?:\\.[\\w-]+)*@(?:[0-9a-zA-Z][-\\w]*[0-9a-zA-Z\\.]){1,2}[a-zA-Z]{2,9})\\z";
final String string = "aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa@test.com";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}