const regex = /\A(?:(?=[a-zA-Z0-9])(?=[\w@\-.]{1,128}\z)(?=[\w.-]+[a-zA-Z0-9]@)[\w-]+(?:\.[\w-]+)*@(?:[0-9a-zA-Z][-\w]*[0-9a-zA-Z\.]){1,2}[a-zA-Z]{2,9})\z/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\A(?:(?=[a-zA-Z0-9])(?=[\\w@\\-.]{1,128}\\z)(?=[\\w.-]+[a-zA-Z0-9]@)[\\w-]+(?:\\.[\\w-]+)*@(?:[0-9a-zA-Z][-\\w]*[0-9a-zA-Z\\.]){1,2}[a-zA-Z]{2,9})\\z', 'gm')
const str = `aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa@test.com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}