using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\A(?:(?=[a-zA-Z0-9])(?=[\w@\-.]{1,128}\z)(?=[\w.-]+[a-zA-Z0-9]@)[\w-]+(?:\.[\w-]+)*@(?:[0-9a-zA-Z][-\w]*[0-9a-zA-Z\.]){1,2}[a-zA-Z]{2,9})\z";
string input = @"aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa@test.com";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}