re = /((`){1,3}|(\*){1,3}|(~){2}|(\|){2}|^(>){1,3}|(_){1,2})+/m
str = '```hello```
`hello`
_hello_
***hello**
**hello**
*hello*
||hello||
> hello
>>> hello'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end