$re = '/((`){1,3}|(\*){1,3}|(~){2}|(\|){2}|^(>){1,3}|(_){1,2})+/m';
$str = '```hello```
`hello`
_hello_
***hello**
**hello**
*hello*
||hello||
> hello
>>> hello';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);