using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((`){1,3}|(\*){1,3}|(~){2}|(\|){2}|^(>){1,3}|(_){1,2})+";
string input = @"```hello```
`hello`
_hello_
***hello**
**hello**
*hello*
||hello||
> hello
>>> hello";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}