#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)((`){1,3}|(\*){1,3}|(~){2}|(\|){2}|^(>){1,3}|(_){1,2})+"
Local $sString = "```hello```" & @CRLF & _
"`hello`" & @CRLF & _
"_hello_" & @CRLF & _
"***hello**" & @CRLF & _
"**hello**" & @CRLF & _
"*hello*" & @CRLF & _
"||hello||" & @CRLF & _
"> hello" & @CRLF & _
">>> hello"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")