re = /^\+20(10|11|12|15)[0-9]{8}$/m
str = '+201001234567
+201101234567
+201201234567
+201501234567'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end