package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\+20(10|11|12|15)[0-9]{8}$`)
var str = `+201001234567
+201101234567
+201201234567
+201501234567`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}