$re = '/^\+20(10|11|12|15)[0-9]{8}$/m';
$str = '+201001234567
+201101234567
+201201234567
+201501234567';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);