const regex = /^\+20(10|11|12|15)[0-9]{8}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\+20(10|11|12|15)[0-9]{8}$', 'gm')
const str = `+201001234567
+201101234567
+201201234567
+201501234567`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}