// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)page\/([0-9]*)\/tag").unwrap();
let string = "<script defer=\"defer\" type=\"text/javascript\" class=\"teads\" src=\"//a.teads.tv/page/123456/tag\"></script>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}