using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"page\/([0-9]*)\/tag";
string input = @"<script defer=""defer"" type=""text/javascript"" class=""teads"" src=""//a.teads.tv/page/123456/tag""></script>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}