package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)page\/([0-9]*)\/tag`)
var str = `<script defer="defer" type="text/javascript" class="teads" src="//a.teads.tv/page/123456/tag"></script>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}