re = /page\/([0-9]*)\/tag/m
str = '<script defer="defer" type="text/javascript" class="teads" src="//a.teads.tv/page/123456/tag"></script>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end