re = /^(?<classname>[\w\.]+)?(?:#(?<member>\w+))$/m
str = 'Moo#withRecipientsWithDefaultName
#withRecipientsWithDefaultName
ClassName#member
ClassName
a.b..ClassName#member
a.b..ClassName'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end