$re = '/^(?<classname>[\w\.]+)?(?:#(?<member>\w+))$/m';
$str = 'Moo#withRecipientsWithDefaultName
#withRecipientsWithDefaultName
ClassName#member
ClassName
a.b..ClassName#member
a.b..ClassName';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);