#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?<classname>[\w\.]+)?(?:#(?<member>\w+))$"
Local $sString = "Moo#withRecipientsWithDefaultName" & @CRLF & _
"#withRecipientsWithDefaultName" & @CRLF & _
"ClassName#member" & @CRLF & _
"ClassName" & @CRLF & _
"a.b..ClassName#member" & @CRLF & _
"a.b..ClassName"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")