package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?<classname>[\w\.]+)?(?:#(?<member>\w+))$`)
var str = `Moo#withRecipientsWithDefaultName
#withRecipientsWithDefaultName
ClassName#member
ClassName
a.b..ClassName#member
a.b..ClassName`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}