re = /(?=.*[a-z])(?=.*[A-Z])(?=.*[0-9])(?=.*[\u0020-\u002f\u003A-\u0040\u005B-\u0060\u007B-\u007E]).{8,}/m
str = 'jhiuyJSY27
HU7987BVF6
HB5rrf67
GH5+m09b
jfi-09uyT
ok8^87VF
09POlo
09nbf4-DE
IGORMARIO
ndjh765b
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end