const regex = new RegExp('(?=.*[a-z])(?=.*[A-Z])(?=.*[0-9])(?=.*[\\u0020-\\u002f\\u003A-\\u0040\\u005B-\\u0060\\u007B-\\u007E]).{8,}', 'gmu')
const str = `jhiuyJSY27
HU7987BVF6
HB5rrf67
GH5+m09b
jfi-09uyT
ok8^87VF
09POlo
09nbf4-DE
IGORMARIO
ndjh765b
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}